Author Topic: New Flare3D 2.5.14 beta is out!  (Read 16480 times)

Ariel Nehmad   «   on: November 21, 2012, 07:34:46 PM »
Hey guys!, new version! :)

Links:
Flare3d 2.5.14 Beta Preview
Flare3d IDE for windows
Flare3d IDE for mac

On the IDE:
* Added gizmos for cameras, lights and pivots.
* Added properties panels for cameras, lights, pivots and the scene.
* Added simultaneous edition in properties panel and mixed types of objects.
* Added full support for ATF textures.
* Fixed an important amount of bugs ;)
* Since these versions are builds in progress, some configurations may be replaced.

On the Library (swc):
* Added full ATF support for rgba, compressed, compressed with alpha and compressed cubemaps.
* Added includeChildren parameter in Mesh3DUtils.merge. By default is false.
* Fixed bug when using mouse events in cloned objects.
* Fixed loaded property in Flare3DLoader.
* Fixed a few minor bugs.

What's next?
We'll be adding full GPU particles on the library and the IDE.

Enjoy :)
Attachments:
« Last Edit: November 27, 2012, 08:39:26 AM by Ariel Nehmad »

Tommy Svensson   «   Reply #1 on: November 22, 2012, 02:41:03 AM »
Very nice! Will we be able to export ATF textures with zf3d? :)

nero king   «   Reply #2 on: November 22, 2012, 03:13:42 AM »
When can we use IDE(plugin) publish F3D file?

James Den   «   Reply #3 on: November 22, 2012, 03:47:42 AM »
ah nvm error fixed :)

thanks for update! looking forward to the particle update any eta for it?
« Last Edit: November 22, 2012, 04:09:40 AM by James Den »

Ariel Nehmad   «   Reply #4 on: November 22, 2012, 04:41:53 AM »
Very nice! Will we be able to export ATF textures with zf3d? :)
On the first stage, if you import an ATF file, we'll export that file, but we plan to add support for batch converting all other textures....maybe some checkbox on export settings could be nice ;)

When can we use IDE(plugin) publish F3D file?
We'll work on that after particles.

thanks for update! looking forward to the particle update any eta for it?
Hopefully next week :)

Shalmu Yakubov   «   Reply #5 on: November 22, 2012, 06:26:44 AM »
Thanks guys, excellent work!
Found one problem: in IDE it's impossible to delete objects from scene, nor it's possible to duplicate anything. Sorry if my humble bugreport is in a wrong place or duplicated :)
« Last Edit: November 23, 2012, 12:09:19 AM by Shalmu Yakubov »

jackie   «   Reply #6 on: November 22, 2012, 09:34:33 AM »
Thanks for you work! I can use my macbook now.

Ariel Nehmad   «   Reply #7 on: November 22, 2012, 05:47:32 PM »
Found one problem: in IDE it's impossible to delete objects from scene, not it's possible to duplicate anything.
Edit tools will be back with undo/redo very soon...the roadmap looks like this:
* Gpu particles
* Export zf3d files
* Edit tools & undo / redo

Akhileshwar Mishra   «   Reply #8 on: November 23, 2012, 05:29:04 PM »
Hello,

Please help -

1) How can I export F3D file from max plug-in of Flare 3D 2.5?
2) How to load .zF3D file in flash?
3) What changes should I make in programme to load a .zF3d format in place of a .F3D file?

Thanks,
Akhil.


Aleksandr Kozlovskij   «   Reply #9 on: November 24, 2012, 10:05:46 AM »
1) How can I export F3D file from max plug-in of Flare 3D 2.5?
2) How to load .zF3D file in flash?
3) What changes should I make in programme to load a .zF3d format in place of a .F3D file?
Akhil,
1. Not implement in exporter-plugin supplied in version 2.5.14.
2. Use 2.5.14 Flare3D swc library.
3. No major changes there.

Akhileshwar Mishra   «   Reply #10 on: November 28, 2012, 12:32:51 PM »
When I replaced "addChildFromFile("abc.f3d")" with addChildFromFile("abcd.zf3d") is not working, why ? its throwing error - unknown file type.
What extra changes shall I do to make it run?



Ivan Vodopiviz   «   Reply #11 on: November 30, 2012, 11:34:13 AM »
Are you sure you're linking to the correct library version? Flare 2.0 cannot open zf3d files, only 2.5 can.

Akhileshwar Mishra   «   Reply #12 on: December 03, 2012, 11:48:21 AM »
I have Flash 5.5 and not 6.0

After I changed the 'Flare3D.swc' to 'Flare3D_2.5.13_Beta_Trial.swc' in the Publish setting - got error -

"VerifyError: Error #1014: Class flash.display3D::Context3D could not be found."

Ariel Nehmad   «   Reply #13 on: December 03, 2012, 11:54:17 AM »
I have Flash 5.5 and not 6.0

After I changed the 'Flare3D.swc' to 'Flare3D_2.5.13_Beta_Trial.swc' in the Publish setting - got error -

"VerifyError: Error #1014: Class flash.display3D::Context3D could not be found."
Hi Akhileshwar, I would recommend to open a different thread for these kind of issues, just to keep things easy to follow ;)

Yvonne Pennant   «   Reply #14 on: December 04, 2012, 05:34:12 PM »
[quote I received this error message "flare.core.Pivot3D.translateZ could be found in Beta 2.5 trial.swc"?
[/quote]

Tags: