Author Topic: Verify Error - Scene3D  (Read 295 times)

Dave   «   on: July 26, 2017, 02:54:43 PM »
I own 2.7.1 commercial, but haven't used it in a while. I have a class path to the swc and I have the swc set in the library path in AS Settings.

Whenever I do a new Scene3D I get this verify error:

VerifyError: Error #1014: Class flare.basic::Scene3D could not be found.

I am importing flare.basic.Scene3D; at the start of my class as well.

I have tried switching commercial to trial swc and get the same thing. Just wondering what will cause this error...

Dave   «   Reply #1 on: July 27, 2017, 04:52:58 AM »
I figured it out. In AS Settings you have to expand the Flare3D SWC line you added to the Library Path. In there you need to change Link Type from 'External' to 'Merged into code'. Once I did that the verify error went away.

Tags: