Author Topic: New Flare3D 2.8.5 is out!  (Read 18547 times)

Ariel Nehmad   «   Reply #30 on: December 02, 2014, 06:39:26 AM »
If I make some changes to the texture compression and save the zf3d, close the editor and reload the zf3d in the editor, it does not load the saved changes for some reason. Is this a known issue?

Also, following the above method, if I save it as a project, it does save it, however, I can no longer drag and drop the zf3d from the project panel into the scene view. Is this also a known issue? Any expected time to resolve these issues?

Yes, that´s correct, that´s because those texture properties are project options, they do not really affect the textures until you actually build those into a new F3D file.
Not sure why you are not able to drag, it should be possible, did you try double click or right click menu -> "Edit"?

Eric Pascal   «   Reply #31 on: December 02, 2014, 08:55:27 AM »
Hello,
I have a very weird problem with only one object of my scene that disappear in version 2.8 and appear in 2.7.
I have to check static property on the object to make it reappear in 2.8.
Do you have any idea where can be the problem ?
I can't send the object because it part of a customer watch.
Thanks

Ariel Nehmad   «   Reply #32 on: December 03, 2014, 10:59:44 AM »
I have a very weird problem with only one object of my scene that disappear in version 2.8 and appear in 2.7.
I have to check static property on the object to make it reappear in 2.8.
Do you have any idea where can be the problem ?
I can't send the object because it part of a customer watch.
Thanks

It may be some issue with the material, but It´s hard to know without more details.
Does the materials have normal maps? vertex colors?

Abhishek   «   Reply #33 on: December 04, 2014, 03:15:11 AM »
Quote
Not sure why you are not able to drag, it should be possible, did you try double click or right click menu -> "Edit"?

No Ariel, that does not work either. It is a real pain when I make a bunch of changes to the zf3d, it does not save the zf3d and neither can I load the same model file from the project. :(

Also, the saved zf3d files in 2.8 do not open in 2.7!!
« Last Edit: December 04, 2014, 04:35:39 AM by Abhishek »

Ariel Nehmad   «   Reply #34 on: December 04, 2014, 10:08:37 AM »
Quote
Not sure why you are not able to drag, it should be possible, did you try double click or right click menu -> "Edit"?

No Ariel, that does not work either. It is a real pain when I make a bunch of changes to the zf3d, it does not save the zf3d and neither can I load the same model file from the project. :(

Also, the saved zf3d files in 2.8 do not open in 2.7!!

I can't be sure, but i think the loader may be crashing somewhere and some things stop working....is it possible to get the saved project? so we can test it here and trace for any possible bug? you can send it to info@ in case you don't want to attach it here.

Johannes   «   Reply #35 on: December 10, 2014, 03:40:08 AM »
Hi, I have been checking out Flare3D 2.8.2 for a bit. Most of our stuff made in Flare3D 2.7.1 just works, which is nice, but some of our stuff doesn't.

I have a ZF3D-file made on version 2.7.1, which works fine there. However, when i open the same file on Flare3D 2.8.2, it shows up as all empty. No errors are displayed either. We can probably recreate the file on v2.8.2, but it is kind of freaky that content is "lost" and no errors are shown. I'd be happy to send you guys this problem-file if you want to take a look at it.

Bonus nitpicking: It would be nice if the many different Save-dialogs in the IDE had set up file extension filters for whatever thing you are currently saving. Right now Flare is claiming to save files as the type *.* which can be confusing.

Ariel Nehmad   «   Reply #36 on: December 10, 2014, 04:10:44 PM »
I have a ZF3D-file made on version 2.7.1, which works fine there. However, when i open the same file on Flare3D 2.8.2, it shows up as all empty. No errors are displayed either. We can probably recreate the file on v2.8.2, but it is kind of freaky that content is "lost" and no errors are shown. I'd be happy to send you guys this problem-file if you want to take a look at it.

Bonus nitpicking: It would be nice if the many different Save-dialogs in the IDE had set up file extension filters for whatever thing you are currently saving. Right now Flare is claiming to save files as the type *.* which can be confusing.

Getting the file would be great!, and will definitely help to know what's happening there!
If you don't want to post it here, please send it to info@

About the filters on saving dialogs, I'm afraid that's an AIR issue, unfortunately it does not provide such option ;(
It's weird, but it is not the same for open dialogs.

Johannes   «   Reply #37 on: December 11, 2014, 01:36:38 AM »
I sent over the file now.

Huh! I did not know that the AIR "Open File" and Save File" dialogs were different like that!

Vincent Vegas   «   Reply #38 on: December 11, 2014, 02:02:27 AM »
I've tried to use the "Mesh3DUtils.merge()" method, but I can't get it working properly.
The merged mesh doesn't appear.

Code: [Select]
var scene:Viewer3D = new Viewer3D(this);
scene.camera = new Camera3D();
scene.camera.setPosition( 0, 5, -5 );
scene.camera.lookAt( 0, 0, 0 );

var cube:Cube = new Cube("", 0.5, 0.5, 0.5);
var list:Vector.<Pivot3D> = new Vector.<Pivot3D>();

for (var i:int = 0; i < 10; i++)
{
var p:Pivot3D = cube.clone();
p.x = i - 4;
p.rotateY(i * 5);
list.push(p);
scene.addChild(p);
}

var merged:Mesh3D = Mesh3DUtils.merge(list, false);
merged.y = -2;
scene.addChild(merged);

Ariel Nehmad   «   Reply #39 on: December 12, 2014, 09:37:03 AM »
I sent over the file now.

Thank you very much for the file, i have found the source of the issue and will try to fix it as soon as possible :)

Ariel Nehmad   «   Reply #40 on: December 12, 2014, 09:45:31 AM »
I've tried to use the "Mesh3DUtils.merge()" method, but I can't get it working properly.
The merged mesh doesn't appear.

Thanks Vincent, I can definitely reproduce this here, not sure why yet, but I'll take a look at that.

Ariel Nehmad   «   Reply #41 on: December 12, 2014, 06:32:40 PM »
Updated downloads links to 2.8.3 :D

* Added a new option, "Embed in Package" for all resources which forces those resources to be included when building the packages, even if those assets are not tied to any 3d model.
This also allows to embed any binary or text file ;)

* Fixed the merge bug and some ZF3D not opening in 2.8.

And more...

Have fun! :)
« Last Edit: December 12, 2014, 06:37:11 PM by Ariel Nehmad »

Ariel Nehmad   «   Reply #42 on: December 15, 2014, 12:47:24 AM »
Another quick update to 2.8.4 :)

* Added "Clean Package" in Package contextual menu to remove all unused resources and a few small fixes.

Eric Pascal   «   Reply #43 on: December 15, 2014, 03:48:04 AM »
I finally managed to reproduce the invisible object problem I have since 2.8 (work on 2.7) on a component that don't belong to our customer.
I have attached the model.
To make it appear select the invisible component and check the static property.

Best Regards,
Attachments:

Ariel Nehmad   «   Reply #44 on: December 15, 2014, 10:56:54 AM »
I finally managed to reproduce the invisible object problem I have since 2.8 (work on 2.7) on a component that don't belong to our customer.
I have attached the model.
To make it appear select the invisible component and check the static property.

Thanks Eric!, I can see the issue and I'm looking at that.